読者です 読者をやめる 読者になる 読者になる

クラスのリネーム

はありですか?

  • StateActivitySelector→DataStateBuriActivitySelector
  • DirectActivitySelector→DirectBuriActivitySelector
  • ParticipantBuriActivitySelector→そのまま
  • StartActivitySelector→StartBuriActivitySelector

と、XxxxBuriActivitySelectorで統一したいなあという気持ちがわいてきたのですが...。


あと、BuriActivityPathFilterの名前もがFilterになっていますが、これをSelectorに統一しようかと思っています。
これをFilterのままで行くとすると、きっとParticipant...もSelectorというよりFilterなのでこれも直さないといけないかなぁと。
名前は、PathBuriActivitySelector あたりですかね。

クラス名の修正がOKだとすれば、クラス名をリファクタリングで修正して、buriSimple.diconとburiStandard.diconも忘れずに修正すればOKですかね。

今のところローカル環境では良い感じです。