読者です 読者をやめる 読者になる 読者になる

SargeなDebianが入ってる玄箱にgitをインストールする

参考: Git入門(さいしょのいっぽ編) - チナミニ


/etc/apt/source.list に以下の1行を追加する。

deb http://www.backports.org/debian sarge-backports main contrib non-free


で、

$ sudo apt-get install git-core
パッケージリストを読みこんでいます... 完了
依存関係ツリーを作成しています... 完了
以下の特別パッケージがインストールされます:
  libcurl3 libdigest-sha1-perl liberror-perl libidn11
提案パッケージ:
  git-doc git-arch git-cvs git-svn git-email git-daemon-run git-gui gitk gitweb libcurl3-gssapi ca-certificates
推奨パッケージ:
  less curl ssh-client
以下のパッケージが新たにインストールされます:
  git-core libcurl3 libdigest-sha1-perl liberror-perl libidn11
アップグレード: 0 個、新規インストール: 5 個、削除: 0 個、保留: 0 個。
3769kB のアーカイブを取得する必要があります。
展開後に追加で 8671kB のディスク容量が消費されます。
続行しますか? [Y/n]
取得:1 ftp://ftp.dti.ad.jp sarge/main libidn11 0.5.13-1.0 [112kB]
取得:2 ftp://ftp.dti.ad.jp sarge/main liberror-perl 0.15-6 [15.3kB]
取得:3 http://www.backports.org sarge-backports/main git-core 1:1.5.4.1-1~bpo31+1 [3373kB]
取得:4 http://security.debian.org sarge/updates/main libcurl3 7.13.2-2sarge5 [243kB]
取得:5 ftp://ftp.dti.ad.jp sarge/main libdigest-sha1-perl 2.10-1 [24.7kB]
3769kB を 21s で取得しました (172kB/s)
未選択パッケージ libidn11 を選択しています。
(データベースを読み込んでいます... 現在 24614 個のファイルとディレクトリがインストールされています。)
(.../libidn11_0.5.13-1.0_powerpc.deb から) libidn11 を展開しています...
未選択パッケージ libcurl3 を選択しています。
(.../libcurl3_7.13.2-2sarge5_powerpc.deb から) libcurl3 を展開しています...
未選択パッケージ liberror-perl を選択しています。
(.../liberror-perl_0.15-6_all.deb から) liberror-perl を展開しています...
未選択パッケージ libdigest-sha1-perl を選択しています。
(.../libdigest-sha1-perl_2.10-1_powerpc.deb から) libdigest-sha1-perl を展開しています...
未選択パッケージ git-core を選択しています。
(.../git-core_1%3a1.5.4.1-1~bpo31+1_powerpc.deb から) git-core を展開しています...
libidn11 (0.5.13-1.0) を設定しています ...

libcurl3 (7.13.2-2sarge5) を設定しています ...

liberror-perl (0.15-6) を設定しています ...
libdigest-sha1-perl (2.10-1) を設定しています ...
git-core (1.5.4.1-1~bpo31+1) を設定しています ...

ってことで、OK.


git-svnは、依存関係がどうもおかしいようで警告が出てしまうのでとりあえずあきらめた。

$ sudo apt-get install git-svn --no-act
パッケージリストを読みこんでいます... 完了
依存関係ツリーを作成しています... 完了
インストールすることができないパッケージがありました。おそらく、ありえ
ない状況を要求したか、必要なパッケージがまだ作成されていなかったり
Incoming から移動されていない、不安定版ディストリビューションを使用し
ているものと考えられます。

単純な操作を行っただけなので、このパッケージは単にインストールできない
可能性が高いです。そのため、このパッケージへのバグレポートを送ってくだ
さい。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージには満たせない依存関係があります:
  git-svn: 依存: libsvn-perl (>= 1.4.2dfsg1-2~bpo.1) しかし、インストールされようとしていません
E: 壊れたパッケージ


ま、とりあえず実行。

$ git --version
git version 1.5.4.1

よっしゃよっしゃ。